Resolved
Email delivery has recovered.
Monitoring
Email delivery is recovering but there may still be delays. We are continuing to monitor the situation.
Investigating
Email delivery is currently delayed. We are working on this issue and expect to resolve it shortly.