Resolved
The performance issue affecting Manage Canada (https://ca.app.clio.com/) has been resolved, and responsiveness is back to normal.
Monitoring
We have deployed a fix and are monitoring. An update will be provided as more information becomes available. |
Investigating
An issue impacting performance in Manage Canada (ca.app.clio.com) is currently under investigation. Some users may experience slower than usual page loads or increased latency. An update will be provided as more information becomes available. |