No components marked as affected
Resolved
The issue affecting downloads in Clio Work in Canada has been resolved, and systems are operating normally.
Identified
The cause of the performance issue affecting document downloads from Vincent CA has been identified, and we're working on restoring full service.
An update will be provided once performance has been restored.
Investigating
An issue affecting the ability to download documents from Vincent conversations in Clio Work is currently under investigation. Some users may experience errors downloading documents from Clio Work in Canada.
An update will be provided as more information becomes available.