Resolved
The incident has been resolved, Clio Manage has returned to normal operation
Monitoring
The issue affecting Clio Manage has been identified and remediated, we are monitoring to ensure we have returned to normal operation
Investigating
An issue affecting the availability of Clio Manage is currently under investigation. Some users may experience errors, slower performance, or difficulty logging in.
An update will be provided as more information becomes available.