Resolved
The performance issues affecting background jobs has been resolved.
Investigating
An issue impacting performance in some areas of Manage EU is currently under investigation. Users may experience slower than usual background tasks and increased latency. An update will be provided as more information becomes available.