Response Time Incident
Incident Report for Clio (US)
Resolved
Performance appears to have returned to normal, though our team will continue to monitor closely.
Posted about 1 year ago. Oct 25, 2017 - 10:20 PDT
Monitoring
We are investigating the cause of a response time spike, which briefly led to reduced site performance for some customers.
Posted about 1 year ago. Oct 25, 2017 - 10:10 PDT