Clio Grow is inaccessible
Incident Report for Clio (US)
Resolved
This issue has been resolved and Clio Grow is now accessible to all Users. We thank you for you patience while we worked to reach a resolution.
Posted 23 days ago. Sep 23, 2019 - 09:33 PDT
Investigating
We are currently investigating an issue affecting access to Clio Grow. More information will be available soon.
Posted 23 days ago. Sep 23, 2019 - 09:30 PDT