Site Performance Incident
Incident Report for Clio (US)
Resolved
Performance has been returned to normal levels, though our Developers will continue to investigate the root issue, and actively monitor the site.
Posted 2 months ago. Oct 10, 2017 - 14:46 PDT
Investigating
We are investigating an issue that temporarily affected site performance. While performance is going back to normal, we have temporarily disabled the Agenda section of the sidebar in the Previous Clio Experience, to help with this, while we continue our investigation.
Posted 2 months ago. Oct 10, 2017 - 13:55 PDT