Service Incident
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted 6 months ago. Dec 03, 2018 - 16:06 PST
Monitoring
Our development team has taken steps to resolve an issue with some pages loading in Clio. They will continue to monitor for any changes in performance, and we regret any disruption this may have caused.
Posted 6 months ago. Dec 03, 2018 - 15:00 PST
Investigating
Our servers are receiving a higher than normal volume of requests and as a result you may experience an issue loading pages in Clio. Our development team is working hard to address the issue, and we will provide an update as soon as possible.
Posted 6 months ago. Dec 03, 2018 - 12:57 PST
This incident affected: Clio (US).