Clio is Inaccessible
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted 6 months ago. May 30, 2018 - 12:17 PDT
Update
We have identified the issue and are working to resolve it.
Posted 6 months ago. May 30, 2018 - 12:15 PDT
Investigating
All Clio users are not able to access their accounts. We are working to identify the cause of the issue. More information will be available soon.
Posted 6 months ago. May 30, 2018 - 12:14 PDT