2019-06-03 Site Issue
Incident Report for Clio (US)
Resolved
An issue that affected loading times for some pages in Clio on Monday, June 3 has now been resolved. We thank you for you patience while we worked to reach a resolution.
Posted 2 months ago. Jun 04, 2019 - 10:52 PDT
Monitoring
We are monitoring an issue that affected loading times for some pages in Clio on Monday, June 3. We thank you for you patience while we continue our investigation.
Posted 3 months ago. Jun 03, 2019 - 14:33 PDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Jun 03, 2019 - 14:17 PDT
Investigating
We are aware of an issue currently affecting our customers and are reviewing the situation. We will provide an update as soon as more information is available.
Posted 3 months ago. Jun 03, 2019 - 09:07 PDT
This incident affected: Clio (US).