Clio Manage Latency US

Incident Report for Clio (US)

Resolved

The incident regarding Clio Manage latency is now resolved. We once again thank you for your patience during this time.
Posted Jan 02, 2026 - 18:53 PST

Monitoring

A fix has been implemented and we are monitoring the results. Thank you.
Posted Jan 02, 2026 - 17:29 PST

Identified

We have identified the cause of latency in Clio Manage. We are currently in the process of fixing this on a long term scale. During this fix, Clio Manage should be accessible. We appreciate your patience and apologize for the interruption this has caused. Thank you.
Posted Jan 02, 2026 - 17:19 PST

Investigating

We are aware of current latency in Clio Manage. We are investigating the issue. We apologize for the inconvenience.
Posted Jan 02, 2026 - 16:53 PST
This incident affected: Clio (US).