Clio Manage is currently experiencing degraded performance
Incident Report for Clio (US)
Resolved
Clio is now fully accessible and the issue has been resolved.
Posted Oct 08, 2020 - 22:16 PDT
Update
We are continuing to investigate this issue.
Posted Oct 08, 2020 - 12:24 PDT
Investigating
We are currently investigating this issue.
Posted Oct 08, 2020 - 10:18 PDT
This incident affected: Clio (US).