Status Update
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted May 31, 2024 - 11:17 PDT
Update
We are continuing to monitor for any further issues.
Posted May 31, 2024 - 07:59 PDT
Monitoring
Between the hours of 7:00 a.m and 11:00 a.m UTC, May 31st, some users may have experienced difficulty logging into Clio.

This access has now been resolved and we are monitoring closely.

We appreciate your patience and apologize for any inconvenience.
Posted May 31, 2024 - 07:10 PDT
Update
We are continuing to investigate this issue.
Posted May 31, 2024 - 04:34 PDT
Update
Clio services may experience intermittent outages, functionality is currently operational and we are monitoring. We apologize for the inconvenience and are working to get this restored as quickly as possible.
Posted May 31, 2024 - 04:33 PDT
Investigating
We are currently investigating the issue.
Posted May 31, 2024 - 03:36 PDT
This incident affected: Clio (US).