Clio is Intermittently Inaccessible

Incident Report for Clio (US)

Resolved

This incident has been resolved.
Posted May 23, 2022 - 09:32 PDT

Investigating

We are aware of an issue where Clio Manage might be inaccessible temporarily and are working on resolving it.
Posted May 23, 2022 - 09:17 PDT
This incident affected: Clio (US).