Clio Manage Matter Pages loading Slow For Users in Texas
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted Sep 19, 2024 - 13:43 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 19, 2024 - 12:43 PDT
Investigating
We are currently investigating reports from users in Texas experiencing slow loading for Clio Manage Matter Pages
Posted Sep 19, 2024 - 11:09 PDT
This incident affected: Clio (US).