Clio is Inaccessible for some accounts
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted 15 days ago. Oct 01, 2019 - 16:03 PDT
Identified
We have identified the issue and are working to resolve it.
Posted 15 days ago. Oct 01, 2019 - 15:59 PDT
Investigating
We are aware of an issue currently affecting access to Clio Manage and are reviewing the situation. We apologize for any inconvenience this may cause and are working to resolve it as soon as possible.
Posted 15 days ago. Oct 01, 2019 - 15:51 PDT
This incident affected: Clio (US).