Clio is Inaccessible
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted over 1 year ago. Jan 29, 2018 - 12:25 PST
Investigating
All Clio users are not able to access their accounts. We are working to identify the cause of the issue. More information will be available soon.
Posted over 1 year ago. Jan 29, 2018 - 12:23 PST