Amazon S3 Outage
Incident Report for Clio (US)
Resolved
The issue now appears to be resolved, and access to all Clio features should be restored. The last update from Amazon was:

"1:05 PM PDT Between 11:40 AM and 12:56 PM PDT we experienced throttling errors accessing Amazon S3 in the US-EAST-1 Region. This issue is resolved and the service is operating normally."
Posted about 1 year ago. Sep 14, 2017 - 13:10 PDT
Update
Update from Amazon:
"12:49 PM PDT We are now seeing recovery in the throttle error rates accessing Amazon S3. We have identified the root cause and have taken actions to prevent recurrence."
Posted about 1 year ago. Sep 14, 2017 - 12:51 PDT
Update
Amazon has posted a further update:
"12:38 PM PDT We continue to work towards resolving the increased throttling errors for Amazon S3 requests in the US-EAST-1 Region. We have identified the subsystem responsible for the errors, identified root cause and are now working to resolve the issue."
Posted about 1 year ago. Sep 14, 2017 - 12:41 PDT
Monitoring
Amazon is currently investigating the root cause, and posting updates under "Amazon Simple Storage Service" on their status page here: https://status.aws.amazon.com/

Their most recent update:
"12:21 PM PDT We can confirm that some customers are receiving throttling errors accessing S3. We are currently investigating the root cause."
Posted about 1 year ago. Sep 14, 2017 - 12:23 PDT
Identified
An issue with Amazon’s servers may cause issues with Clio’s Documents, Reports, and a few other features which rely on this service. We are attempting to mitigate the impact as much as possible until Amazon has resolved the issue
Posted about 1 year ago. Sep 14, 2017 - 12:02 PDT