Service Incident
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted Jan 19, 2021 - 10:35 PST
Investigating
We are aware of an issue currently affecting some areas of Clio and are reviewing the situation. We apologize for any inconvenience this may cause and are working to resolve it as soon as possible.
Posted Jan 19, 2021 - 09:49 PST
This incident affected: Clio (US).