Clio is Inaccessible
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 06, 2019 - 19:31 PDT
Update
We have identified the issue and are working to resolve it.
Posted 3 months ago. Jul 06, 2019 - 19:30 PDT
Investigating
All Clio users are not able to access their accounts. We are working to identify the cause of the issue. More information will be available soon.
Posted 3 months ago. Jul 06, 2019 - 19:30 PDT