Site Performance Incident
Incident Report for Clio (US)
Resolved
As of 9am PST, the issue with loading some pages in Clio has been resolved. Our development team continues to investigate and take steps to prevent this issue from reoccurring.
Posted 5 months ago. Jul 16, 2018 - 09:31 PDT
Update
Our servers are experiencing a higher than normal volume of requests and as a result you may experience an issue loading some pages in Clio. Our development team is working hard to resolve the issue as soon as possible.
Posted 5 months ago. Jul 16, 2018 - 08:49 PDT
Investigating
We are aware of an issue currently affecting our customers and are reviewing the situation. We will provide an update as soon as more information is available.
Posted 5 months ago. Jul 16, 2018 - 08:21 PDT
This incident affected: Clio (US).