Clio Payments Degradation of Service
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted Apr 06, 2021 - 14:52 PDT
Monitoring
We are continuing to monitor an issue affecting Clio Payments. We apologize for any inconvenience this may cause.
Posted Apr 06, 2021 - 14:40 PDT
Investigating
We are aware of an issue currently affecting Clio Payments and are working with LawPay to review the situation. We apologize for any inconvenience this may cause and are working to resolve it as soon as possible.
Posted Apr 06, 2021 - 14:30 PDT
This incident affected: Clio (US).