Login Issue
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted Feb 21, 2020 - 13:03 PST
Monitoring
The issue affecting the ability to log into Clio has been resolved. Thank you for your patience.
Posted Feb 21, 2020 - 12:56 PST
Update
We are currently investigating an issue affecting the ability to log into Clio.
Posted Feb 21, 2020 - 12:30 PST
Investigating
We are currently investigating an issue affecting logging into Clio.
Posted Feb 21, 2020 - 12:28 PST
This incident affected: Clio (US).