Service Incident
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted 19 days ago. Oct 01, 2018 - 11:37 PDT
Monitoring
Our servers experienced a higher than normal volume of requests and as a result you may have experienced an issue loading pages in Clio. Our Developers have resolved the issue, and are investigating the root cause to prevent future issues.
Posted 19 days ago. Oct 01, 2018 - 11:17 PDT
Investigating
We are aware of an issue currently affecting our customers and are currently reviewing the situation. We are in the process of gathering information and will provide an update as soon as possible.
Posted 19 days ago. Oct 01, 2018 - 10:28 PDT
This incident affected: Clio (US).