3rd Party App Degradation of Service
Incident Report for Clio (US)
Resolved
Our third-party app integration Faster Suite has returned to normal performance levels. We will continue to monitor for any changes.
Posted Dec 30, 2020 - 10:40 PST
Update
Our third-party app integration Faster Suite is experiencing slower than normal updates. Find out more here: https://support.clio.com/hc/en-us/articles/1260800875849
Posted Dec 28, 2020 - 12:36 PST
Update
Our third-party app integration Faster Suite may continue to experience slower than normal updates. Thank you for your patience.
Posted Dec 22, 2020 - 16:01 PST
Monitoring
Clio is now fully accessible and the issue has been resolved. Some third-party app integrations may experience slower than normal updates for a short period. Thank you for your patience.
Posted Dec 21, 2020 - 09:44 PST
This incident affected: Clio (US).