Slowness
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 14:55 PST
Monitoring
We are continuing to monitor speed and performance of Clio.
Posted Jan 25, 2021 - 17:04 PST
Investigating
We are aware of an issue currently affecting Clio's speed and are reviewing the situation. We apologize for any inconvenience this may cause and are working to resolve it as soon as possible.
Posted Jan 25, 2021 - 10:21 PST
This incident affected: Clio (US).