Degradation of Service
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted Dec 21, 2020 - 09:22 PST
Investigating
We are working to address an issue affecting page load times and errors in Clio. We apologize for any inconvenience and thank you for your patience.
Posted Dec 21, 2020 - 08:11 PST
This incident affected: Clio (US).