Clio is Inaccessible

Incident Report for Clio (US)

Resolved

This incident has been resolved.
Posted Feb 22, 2023 - 10:21 PST

Update

We have identified the issue and are working to resolve it.
Posted Feb 22, 2023 - 10:19 PST

Investigating

All Clio users are not able to access their accounts. We are working to identify the cause of the issue. More information will be available soon.
Posted Feb 22, 2023 - 10:15 PST