Clio is Inaccessible for some accounts
Incident Report for Clio (US)
Resolved
Clio Manage should now be accessible to all customers. We will continue to monitor this issue with Amazon.
Posted Oct 22, 2019 - 14:42 PDT
Identified
We are aware of an issue with Amazon Web Services currently affecting access to Clio Manage. We apologize for any inconvenience this may cause and are working to resolve it as soon as possible.
Posted Oct 22, 2019 - 12:28 PDT
Investigating
We are aware of an issue currently affecting access to Clio Manage and are reviewing the situation. We apologize for any inconvenience this may cause and are working to resolve it as soon as possible.
Posted Oct 22, 2019 - 12:00 PDT
This incident affected: Clio (US).