Degradation of Service

Incident Report for Clio (US)

Resolved

This incident has been resolved.
Posted Mar 01, 2021 - 16:52 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 01, 2021 - 16:40 PST

Investigating

We are aware of an issue currently affecting loading some pages and are reviewing the situation. We apologize for any inconvenience this may cause and are working to resolve it as soon as possible.
Posted Mar 01, 2021 - 16:14 PST
This incident affected: Clio (US).