Clio is inaccessible
Incident Report for Clio (US)
Resolved
Our team has resolved the issue and all customers should now be able to access Clio. Thank you for your patience.
Posted 7 months ago. Feb 19, 2019 - 14:26 PST
Identified
Our team has identified a possible issue and is working quickly to resolve it. We will continue to update this page as more information becomes available.
Posted 7 months ago. Feb 19, 2019 - 14:24 PST
Investigating
All Clio users are not able to access their accounts. We are working to identify the cause of the issue. More information will be available soon.
Posted 7 months ago. Feb 19, 2019 - 14:00 PST
This incident affected: Clio (US).