Site Performance Incident
Incident Report for Clio (US)
Resolved
Our servers experienced a higher than normal volume of requests and as a result you may have experienced an issue loading pages in Clio. The situation has now been resolved. We will continue to monitor and investigate the issue. Thank you for your patience.
Posted about 1 year ago. Jul 26, 2018 - 09:25 PDT
Investigating
We are aware of an issue currently affecting our customers and are in the process of reviewing the situation. We will provide an update as soon as possible.
Posted about 1 year ago. Jul 26, 2018 - 09:17 PDT
This incident affected: Clio (US).