Document Generation Degradation of Service
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted Apr 15, 2021 - 12:37 PDT
Investigating
We are aware of an issue currently affecting bill logos and other images and are reviewing the situation. We apologize for any inconvenience this may cause and are working to resolve it as soon as possible.
Posted Apr 15, 2021 - 12:26 PDT
This incident affected: Clio (US).