Clio is Inaccessible for some users
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted about 1 year ago. Sep 24, 2018 - 13:33 PDT
Investigating
We are aware of an issue currently affecting our customers and are reviewing the situation. We will provide an update as soon as more information is available.
Posted about 1 year ago. Sep 24, 2018 - 13:32 PDT
This incident affected: Clio (US).