Service Incident
Incident Report for Clio (US)
Resolved
We have resolved an issue which caused a number of operations including report and bill generation, to not complete as expected. We apologize for any disruption, and will be actively monitoring this for the rest of the day.
Posted 7 months ago. Dec 10, 2018 - 11:56 PST
Investigating
We are aware of an issue currently affecting our customers and are reviewing the situation. We will provide an update as soon as more information is available.
Posted 7 months ago. Dec 10, 2018 - 11:13 PST
This incident affected: Clio (US).