Clio is Inaccessible
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted 10 months ago. Feb 16, 2018 - 05:28 PST
Update
We have identified the issue and are working to resolve it.
Posted 10 months ago. Feb 16, 2018 - 05:28 PST
Investigating
All Clio users are not able to access their accounts. We are working to identify the cause of the issue. More information will be available soon.
Posted 10 months ago. Feb 16, 2018 - 05:27 PST