Clio is Loading slow
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 06:27 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2024 - 06:15 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 18, 2024 - 05:39 PDT
Investigating
Clio users might see slow webpage loading times. We are working to identify the cause of the issue. More information will be available soon.
Posted Mar 18, 2024 - 05:30 PDT
This incident affected: Clio (US).