Clio is Inaccessible
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted 11 months ago. Jun 06, 2018 - 21:02 PDT
Investigating
All Clio users are not able to access their accounts. We are working to identify the cause of the issue. More information will be available soon.
Posted 11 months ago. Jun 06, 2018 - 21:00 PDT