Third Party App Degradation of Service
Incident Report for Clio (US)
Resolved
Updates with FasterSuite have now returned to normal. Thank you for your patience.
Posted Mar 04, 2021 - 17:54 PST
Monitoring
Our third-party app integration Faster Suite is experiencing slower than normal updates. We are monitoring and attempting to resolve the situation.
Posted Mar 04, 2021 - 17:17 PST
This incident affected: Clio (US).