Clio Degraded Performance

Incident Report for Clio (US)

Resolved

Reported performance issues and errors logging into Clio products have been resolved.
Posted May 28, 2025 - 10:17 PDT

Investigating

We are currently investigating reports of issues logging into Clio Apps and intermittent application errors.
Posted May 28, 2025 - 09:59 PDT
This incident affected: Clio (US).