Clio is Inaccessible
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted 11 months ago. Sep 26, 2018 - 14:29 PDT
Update
We have identified the issue and are working to resolve it.
Posted 11 months ago. Sep 26, 2018 - 14:29 PDT
Investigating
All Clio users are not able to access their accounts. We are working to identify the cause of the issue. More information will be available soon.
Posted 11 months ago. Sep 26, 2018 - 14:28 PDT