Clio is Inaccessible
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted about 1 year ago. Nov 06, 2017 - 12:11 PST
Investigating
All Clio users are not able to access their accounts. We are working to identify the cause of the issue. More information will be available soon.
Posted about 1 year ago. Nov 06, 2017 - 12:10 PST