Clio is Inaccessible
Incident Report for Clio (US)
Resolved
This incident has been resolved.
Posted Jan 25, 2021 - 17:45 PST
Investigating
All Clio users are not able to access their accounts. We are working to identify the cause of the issue. More information will be available soon.
Posted Jan 25, 2021 - 17:44 PST